Sie sind nicht angemeldet.

Bitte schaut euch auch ruhig den aktuellen Entwicklungsstand der Emu64 Version 5.xx an. Diese läuft schon recht stabil und rückt dem Ende der Portierung (Linux/windows) Woche für Woche immer näher.
https://github.com/ThKattanek/emu64

Kontrollzentrum

Geburtstage

Heute hat niemand Geburtstag.

Neue Benutzer

janney(1. Mai 2018, 08:15)

rba1207(7. April 2018, 10:35)

luck42(16. März 2018, 13:03)

MiniWiesel1512(18. Januar 2018, 18:23)

Shooter(12. Januar 2018, 23:11)

Zur Zeit sind keine Benutzer aktiv.

Statistik

  • Mitglieder: 841
  • Themen: 1110
  • Beiträge: 7142 (ø 1,5/Tag)
  • Wir begrüßen unser neuestes Mitglied: janney

Umfrage

Lieber Besucher, herzlich willkommen bei: Emu64. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Thorsten Kattanek

Emu64 - Entwickler

  • »Thorsten Kattanek« ist männlich
  • »Thorsten Kattanek« ist der Autor dieses Themas
  • Deutschland

Beiträge: 1 310

Wohnort: Berlin

Beruf: Staatlich geprüfter Techniker in Elektrotechnik / Informatik

  • Nachricht senden

1

Dienstag, 3. September 2019, 21:32

Emu64 Release Update auf 5.0.17

Emu64 Release Update auf 5.0.17

Unter https://github.com/ThKattanek/emu64/releases findet ihr die Windows Versionen
Linux User bitte selber kompilieren. Anleitungen dazu findet ihr hier --> https://github.com/ThKattanek/emu64/wiki

5.0.17
  • Portierung von Qt4 nach Qt5
  • [issue #135] Im Debugger kam es zu einem Absturz wenn man in der ASM Zeile ein NOP eingegeben hat.
  • ZIP Support kann man in der qmake Projektdatei auskommentieren (wenn man probleme mit quazip hat)
  • von cmake wieder zurück zum Buildsystem qmake
  • G64 File könne wieder geladen werden (Inhalt wird aber im FloppyWindow und FloppyStatus "noch" nicht angezeigt)
  • Anzahl der GAP Bytes bei der D64->GCR Konvertierung angepasst
  • Kontextmenü im D64 Verzeichnis um einen Punkt erweiter -> "Laden ohne Kernal". Die Datei wird einfach ins RAM geschrieben ohne auszuführen
  • [issue #134] Spiel Benji Space Rescue startet nun (Nach einem CLI wenn die IRQ Leitung noch Low ist, wird der nächste Befehl noch abgearbeitet und kein IQR ausgelöst )
  • 6510 IQR/NMI div. Änderungen
  • VIC Einstellungen hinzugefügt
    - Sprite View on/off
    - Border View on/off
    - Sprite - Sprite Kollision on/off
    - Sprite - Background Kollision on/off
    - Grey Dots on/off
  • [issue #143] Div. Demos kein Sound. Bei einem ReadOnly Register wird immer der zuletzt im SID geschriebener Wert zurückgegeben. Das für ca. 2000-4000 Zyklen. Danach wir 0 zurückgegeben.
  • Grey Dots werden jetzt wieder angezeigt. (Abschaltbar)
  • [issue #152] Erste und letzte Display Zeile wurde neu festgelegt. Erste Sichtbare Zeile: 26 Letzte Sichtbare Zeile: 292 Das ganze ist über die emu64.ini einstellbar und zwar für PAL und NTSC getrennt.
  • SID Dump wieder hinzugefügt
  • Konsolenmeldung: libpng warning: iCCP: known incorrect sRGB profile --> gefixt
  • [issue #153] Tape Record funktioniert wieder
  • Tape Soundausgabe funktioniert wieder richtig
  • Virtuelle C64 Tastatur: Funktionstasten F2,F4,F6,F8,CRSR hoch und runter funktionieren nun ohne gedrückte Shift Taste.
  • Absturz in Virtueller C64 Tastatur behoben, wenn außerhalb der Tasten geklickt wurde
  • Soundausgabe überarbeitet
  • 16-bit Videomode komplett entfernt
  • Logmeldungen erweitert
  • Emu64 Start, beschleunigt. Sollte wieder zügig starten
  • [issue #137] Sreenshots von F9 auf F11 verlagert, funktioniert nun aber im Hauptfenster und im C64 Bildschirm
  • Hardreset per Shift-F12 funktioniert nun auch
  • [issue #96] ZIP Support funtioniert nun wieder im Floppy, Cartridge und Tape Fenster
  • D64 Directory Darstellung im Haupt- und im Floppyfenster gefixt
  • Quellcode teilweise aufgeräumt und einige Warnings entfernt


MfG Thorsten Kattanek

  • »Andreas Goller« ist männlich
  • Deutschland

Beiträge: 816

Wohnort: Rastatt

Beruf: Bauzeichner - halbtags

  • Nachricht senden

2

Samstag, 7. September 2019, 19:17

Hi Thorsten

Klasse das es mal wieder was neues gibt vom Emu64. Habe echt gedacht das du das eingestellt hast. Um so mehr freue ich mich das es weider geht. :D


Gruß Andreas


-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
07.09.2019 - 19:30

Hi Thorsten
Wollte dir mitteilen das man bei der neuen Version 5.0.17 64 Bit keine Cartridge mehr laufen. Ich habe Sie auf jedenfall nicht zum laufen gebracht.
Ebenso das Floppy. Das Directrory der D64-Datei wird nicht angezeigt

Wenn ich noch was finden soll melde ich es gleich auf deine Seite für Fehler.

Gruß Andreas
Ich liebe den Sound vom C64´er 8o 8o

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »Andreas Goller« (7. September 2019, 19:38)


Thorsten Kattanek

Emu64 - Entwickler

  • »Thorsten Kattanek« ist männlich
  • »Thorsten Kattanek« ist der Autor dieses Themas
  • Deutschland

Beiträge: 1 310

Wohnort: Berlin

Beruf: Staatlich geprüfter Techniker in Elektrotechnik / Informatik

  • Nachricht senden

3

Sonntag, 8. September 2019, 14:03

Ich lass doch mein Herzensprojekt nicht einfach so fallen. Never ;) Oh mit die Fehlern ist ja blöd. Hatte einige CRT's getestet auch D64 Images da lief das bei mir. Lade mal bei GitHub zu den Issues auch die entspr. Files mit hoch, die nicht funktionieren. So kann das ich das besser testen und ausprobieren ;) Evtl. wieder irgendwas mit dem Pfad. Hatten wir bei dir schon mal. Am besten auch die emu64.log mit hochschieben :)

  • »Andreas Goller« ist männlich
  • Deutschland

Beiträge: 816

Wohnort: Rastatt

Beruf: Bauzeichner - halbtags

  • Nachricht senden

4

Sonntag, 8. September 2019, 14:27

Hi Thorsten
Das ist eine klare Aussage. Finde ich echt prima das du das weider machst.
So hier mal die Emu64.Log

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
*** Emu64 Win32 Binary File ***

Emu64 Version: 5.0.17

>> Data Path = F:/C64er/C64 Emulatoren/Emu - Emu64 V5.0.17
>> System Temp Path: C:/Users/rasta/AppData/Local/Temp
>> Emu64 Temp Path: C:/Users/rasta/AppData/Local/Temp/emu64
>> Screenshot Path = C:/Users/rasta/.config/emu64/screenshots
>> INI System wurde erzeugt: C:/Users/rasta/.config/emu64/emu64.ini
>> INI System was created: C:/Users/rasta/.config/emu64/emu64.ini
>> Sprachmenü wurde erstellt.de
>> Translator wurde installiert: Systemsprache = de
>> Ein RomSet Verzeichnis ist vorhanden
>> romsetPath = C:/Users/rasta/.config/emu64/romsets/
>> Das Screenshot Verzeichnis ist vorhanden
>> VideoPal Klasse wurde installiert
>> C64 Klasse wurde gestartet...
>> GfxPath = F:/C64er/C64 Emulatoren/Emu - Emu64 V5.0.17/gfx/
>> SDL2 wurde installiert
>> Folgendes Bild wurde erfolgreich geladen --- F:/C64er/C64 Emulatoren/Emu - Emu64 V5.0.17/gfx/pfeil0.png
>> Folgendes Bild wurde erfolgreich geladen --- F:/C64er/C64 Emulatoren/Emu - Emu64 V5.0.17/gfx/pfeil1.png
>> Folgendes Bild wurde erfolgreich geladen --- F:/C64er/C64 Emulatoren/Emu - Emu64 V5.0.17/gfx/kreis0.png
>> Folgendes Bild wurde erfolgreich geladen --- F:/C64er/C64 Emulatoren/Emu - Emu64 V5.0.17/gfx/kreis1.png
>> SDL_Audio wurde installiert
	 -Audio Driver: directsound
	 -Audio Channels: 2
	 -Audio Buffersize: 981
	 -Audio Sample Bit Size: 32
	 -Audio Sample Is Float: 1
	 -Audio Sample Is Signed: 0
	 -Audio Sample Is Little Endian: 1
>> SDL Subsytem Joystick wurde erfolgreich geoeffnet
>> SDL konnte 1 Joystick/Gamepad erkennen
>>   [00] Generic   USB  Joystick  
>> InfoWindow wurde erzeugt
>> VideoCrtSetupWindow wurde erzeugt
>> FloppyWindow wurde erzeugt
>> TapeWindow wurde erzeugt
>> C64KeyboardWindow wurde erzeugt
>> CrtWindow wurde erzeugt
>> DebuggerWindow wurde erzeugt
>> SetupWindow wurde erzeugt
>> C64SpeedWindow wurde erzeugt
>> ShowC64KeyMapWindow wurde erzeugt
>> VideoCaptureWindow wurde erzeugt
>> SidDumpWindow wurde erzeugt
>> Aktuelle Screenshotnummer wurde geladen
>> DebuggerWindow wurde mit C64 Klasse verbunden
>> C64SpeedWindow wurde mit C64 Klasse verbunden
>> CRT LED wurde mit CrtWindow verbunden
>> Alle C64 Roms geladen
>> C64 Key-Matrix wurde mit Virtual Keyboard verbunden
>> Tabelle für alle Floppy Laufwerke wurde erzeugt
>> Alle Floppy Lauferke in Tabelle eingetragen
>> SDL Window Close Event mit MainWindow verknuepft
>> C64Class LimitCycelsEvent mit MainWindow verknuepft
>> C64Class DebugCartEvent mit MainWindow verknuepft
>> ChangeFloppyImage Event mit MainWindow verknuepft
>> FloppyWindow LoadIni wurde ausgefuehrt
>> Change Grafik Mode: 1-0-0
>> SetupWindow LoadIni wurde ausgefuehrt
>> CrtWindow LoadIni wurde ausgefuehrt
>> TapeWindow LoadIni wurde ausgefuehrt
>> C64 Tastatur Mapping aus INI geladen
>> Emu64 wurde initialisiert


>> Splashsreen wurde geschlossen.
>> C64 Emulation wird gestartet.
>> SDLThread Start.
>> C64Thread wurde gestartet.
>> SDLThread: InitGrafik Start.
>> SDL Audiostream wurde getartet.
	InitGrafik: Warten bis Vic-Refresh angehalten wurde.
>> C64 Emulation wurde gestartet.
	InitGrafik: Vic-Refresh wurde angehalten.
	InitGrafik: EnableFullscreen: 0
	InitGrafik: WindowWidth: 768, WindowHeight: 532
	InitGrafik: C64ScreenWidth: 768, C64ScreenHeight: 532
	InitGrafik: WindowColorBits: 32
	InitGrafik: EnableVideoCrtOutput: 0
	InitGrafik: EnableVideoDoubleSize: 1
	InitGrafik: SDL_Window noch nicht vorhanden.
>> Hardreset wurde ausgefuehrt.
	InitGrafik: SDL_Window wurde erstellt (768,532).
	InitGrafik: SDL_Window Icon wurde gesetzt.
	InitGrafik: GLContext wurde erstellt.
	InitGrafik: GLVieport wurde gesetzt.
	InitGrafik: GLOrtho wurde gesetzt.
	InitGrafik: C64 Screen Textur wurde generiert.
	InitGrafik: C64 Screen Textur wurde gebunden.
	InitGrafik: Screenfilter ist deaktiviert.
	InitGrafik: C64Screen - SDL RGB Surface wurde erstellt.
	InitGrafik: 2DTexturImage wurde aus C64ScreenBuffer erstellt.
	InitGrafik: Textur ImgJoyArrow0 wird erstellt.
	InitGrafik: Textur konnte erstellt werden.
	InitGrafik: Textur ImgJoyArrow1 wird erstellt.
	InitGrafik: Textur konnte erstellt werden.
	InitGrafik: Textur ImgJoyButton0 wird erstellt.
	InitGrafik: Textur konnte erstellt werden.
	InitGrafik: Textur ImgJoyButton1 wird erstellt.
	InitGrafik: Textur konnte erstellt werden.
	InitGrafik: Vic-Refresh wurde wieder freigegeben.
>> SDLThread: InitGrafik Ende.
>> SDLThread Ende
>> SDL Subsystem Joystick wurde geschlossen
>> Es wurden alle Klassen wieder entfernt

>> Emu64 wurde sauber beendet...

Seit wann gibt es hier keinen Anhang mehr. Ist mir nie aufgefallen das der hier fehlt.
Hoffe es hielft dir weiter.
Gruß Andreas
Ich liebe den Sound vom C64´er 8o 8o

Thorsten Kattanek

Emu64 - Entwickler

  • »Thorsten Kattanek« ist männlich
  • »Thorsten Kattanek« ist der Autor dieses Themas
  • Deutschland

Beiträge: 1 310

Wohnort: Berlin

Beruf: Staatlich geprüfter Techniker in Elektrotechnik / Informatik

  • Nachricht senden

5

Dienstag, 10. September 2019, 07:29

Hi Andi!
Log sieht erst mal gut aus. Kannst du mir die Dateien einfach mal per Mail schicken, damit ich das hier nachvollziehen kann. ;) Evtl. muss ich das Logging im Emu64 noch erweitern um den Fehler auf die Schliche zu kommen. Aber das sehen wir dann, würde dir dann wieder aktuelle Emu64 Builds zukommen lassen.

Werde demnächst das Forum mal Grundsanieren, damit alles wieder läuft wie gehabt.
MfG Thorsten

  • »Andreas Goller« ist männlich
  • Deutschland

Beiträge: 816

Wohnort: Rastatt

Beruf: Bauzeichner - halbtags

  • Nachricht senden

6

Dienstag, 10. September 2019, 22:25

Hi Thorsten
E-Mail Erfolgreich verschickt. :)

Gruß Andi
Ich liebe den Sound vom C64´er 8o 8o

Thorsten Kattanek

Emu64 - Entwickler

  • »Thorsten Kattanek« ist männlich
  • »Thorsten Kattanek« ist der Autor dieses Themas
  • Deutschland

Beiträge: 1 310

Wohnort: Berlin

Beruf: Staatlich geprüfter Techniker in Elektrotechnik / Informatik

  • Nachricht senden

7

Mittwoch, 11. September 2019, 07:19

Hallo Andi,

E-Mail ist angekommen und Download funktionierte auch. Ich wollte aber eigtl. nicht die Emu64 Version die habe ich ja selber ;) Ich wollte die D64 Images die nicht laufen, um diese hier zu Testen. (Habe mich aber auch blöd ausgedrückt :D)

Oder läuft gar keines bei Dir? Wäre schon komisch. Kannst du mal testen wenn du ein D64 Image z.B. direkt in C:\ ablegst und dieses versuchst zu laden ob das klappt. Ansonsten schicke mir doch mal bitte den kompletten Pfad zu den D64 Images mit Namen. z.b "C:\c64\d64_images\super_game.d64". Danke Dir !MfG Thorsten

  • »Andreas Goller« ist männlich
  • Deutschland

Beiträge: 816

Wohnort: Rastatt

Beruf: Bauzeichner - halbtags

  • Nachricht senden

8

Donnerstag, 12. September 2019, 09:01

Hi Thorsten
OK dann habe ich dich falsch verstanden.

So ich habe mal die D64 Images mal direkt mit "öffne mit " ausgeführt. Der Emu64 startet aber läd das Spiel nicht. Ich habe verschiedene Spiele probiert. Kein Spiel wurde gestartet.

Und selbst die Einzelprogramme werden nicht ausgeführt.

Und hier mal ein Bild von meinen Floppy-Fenster, wenn ich es darüber machen möchte.

Link:

https://www.bilder-upload.eu/bild-f38f5a-1568271209.png.html
Aber Thorsten kann es eventuell am Windows 10 liegen. Habe die Ver 1903 (Build 18362.295)

Denn ich vermute das es bei dir läuft.
Gruß Andi
Ich liebe den Sound vom C64´er 8o 8o

Thorsten Kattanek

Emu64 - Entwickler

  • »Thorsten Kattanek« ist männlich
  • »Thorsten Kattanek« ist der Autor dieses Themas
  • Deutschland

Beiträge: 1 310

Wohnort: Berlin

Beruf: Staatlich geprüfter Techniker in Elektrotechnik / Informatik

  • Nachricht senden

9

Donnerstag, 12. September 2019, 10:33

Hi Andi!
an Windows 10 liegt es nicht. Ich habe Emu64 auch unter Win10 getestet. Ich habe mal den Datei-Pfad aus deinem Screenshot nachgestellt und siehe da, er lädt bei mir auch nicht aus diesen Pfad. Das ist soweit Super, da ich hier den Fehler nachstellen kann, und auf Suche gehen kann. Damit du trotzdem spielen kannst, kopiere die entspr. D64 einfach z.b. nach C:\D64
ohne irgendwelche Sonderzeichen in dem Verzeichnissen.

Daraus sollte Emu64 die Images lesen können. Woran es nun genau liegt muss ich erst raus finden, aber sollte kein Problem sein :) Ich gebe dir Bescheid sobald ich das gefixt habe.
MfG Thorsten

  • »Andreas Goller« ist männlich
  • Deutschland

Beiträge: 816

Wohnort: Rastatt

Beruf: Bauzeichner - halbtags

  • Nachricht senden

10

Donnerstag, 12. September 2019, 21:13

Hi Thorsten
Alles klar, kann es aber erst am Wochenende testen. Habe einen Rechner zur Reparatur hier bei mir.

Gruß Andi
*************************************************************************************************
So wir haben jetzt 22:07 - 12-09-2019
Also es hat mir keine Ruhe gelassen, habe es jetzt getestet. wenn ich meine Spiele gleich am Anfang der Root platziere, ohne zick Unterverzeiche findet der Emu64 die Spiele und die laufen auch.
Also alles Gut. Werde in den nächsten Tage mal ein paar neue Cartridge-Spiele testen, ins besonders das Mario Spiel. :D
Gruß Andi
Ich liebe den Sound vom C64´er 8o 8o

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Andreas Goller« (12. September 2019, 22:12)


Thorsten Kattanek

Emu64 - Entwickler

  • »Thorsten Kattanek« ist männlich
  • »Thorsten Kattanek« ist der Autor dieses Themas
  • Deutschland

Beiträge: 1 310

Wohnort: Berlin

Beruf: Staatlich geprüfter Techniker in Elektrotechnik / Informatik

  • Nachricht senden

11

Freitag, 13. September 2019, 21:03

Hallo Andi!
Mir hat das auch keine Ruhe gelassen. Ich denke ich habe den Fehler gefunden und auch behoben. Jetzt solltest du auch die Dateien aus deinem Verzeichnis laden können :)
Ich hab mal hier die aktuelle Version verlinkt. Gib mal bescheid ob die jetzt bei dir läuft, dann kann ich den Issue auf GitHub schließen. Schönen Abend und ein schönes Wochenende.

Meinst du das Mario hier ?



http://www.emu64-projekt.de/Files/emu64_…3d69_win_x32.7z
http://www.emu64-projekt.de/Files/emu64_…3d69_win_x64.7z
MfG Thorsten

  • »Andreas Goller« ist männlich
  • Deutschland

Beiträge: 816

Wohnort: Rastatt

Beruf: Bauzeichner - halbtags

  • Nachricht senden

12

Samstag, 14. September 2019, 16:50

Hi Thorsten
Werde das gleich heute Abend testen. :)
Leider kann ich das Bild nicht sehen, warum auch immer. Die Funktion Bildeinfügen mit Link klappt nie so richtig hier, deswegen habe ich dir den Link direkt geschickt.
Ich meine dieses Mario
https://ibb.co/BfbTCbT
Ich gehe davon aus du du das selbe meinst. Denn dieses Mario hatt große Welle geschlagen, denn es war Ruck-Zuck weg. Nintento hatte was dagegen.

Wenn ich was finde gebe ich dir Bescheid hier im Forum, damit es noch ein wenig genutzt wird.

Gruß Andi - freu :D :thumbsup:
Ich liebe den Sound vom C64´er 8o 8o

Thorsten Kattanek

Emu64 - Entwickler

  • »Thorsten Kattanek« ist männlich
  • »Thorsten Kattanek« ist der Autor dieses Themas
  • Deutschland

Beiträge: 1 310

Wohnort: Berlin

Beruf: Staatlich geprüfter Techniker in Elektrotechnik / Informatik

  • Nachricht senden

13

Samstag, 14. September 2019, 23:10

Hi Andi,
ja genau dieses Mario meine ich auch. :D Das mit dem Forum wird sich bald wieder ändern. Es wird in absehbarer Zeit hier einiges passieren, bin da mit Thomas im Gespräch. :thumbsup:
MfG Thorsten

  • »Andreas Goller« ist männlich
  • Deutschland

Beiträge: 816

Wohnort: Rastatt

Beruf: Bauzeichner - halbtags

  • Nachricht senden

14

Samstag, 14. September 2019, 23:20

Hi Thorsten
Also ich habe jetzt mal ein paar CRT getestet, alle liefen bis auf das Mario-Spiel. Der Bildschirm bleibt schwarz.
Ich schicke dir gleich mal diese Cartridge. Hoffe du kannst da was machen.
Gruß Andi
Ich liebe den Sound vom C64´er 8o 8o

Thorsten Kattanek

Emu64 - Entwickler

  • »Thorsten Kattanek« ist männlich
  • »Thorsten Kattanek« ist der Autor dieses Themas
  • Deutschland

Beiträge: 1 310

Wohnort: Berlin

Beruf: Staatlich geprüfter Techniker in Elektrotechnik / Informatik

  • Nachricht senden

15

Samstag, 14. September 2019, 23:24

Hi Andi, ja schicke mir das CRT mal. Als vorübergehende Lösung kann ich dir die DISK Version schicken. Die läuft auf Emu64. Aber die CRT Version hätte ich auch gerne, das sie auf Emu64 läuft. ;)
MfG Thorsten

Thorsten Kattanek

Emu64 - Entwickler

  • »Thorsten Kattanek« ist männlich
  • »Thorsten Kattanek« ist der Autor dieses Themas
  • Deutschland

Beiträge: 1 310

Wohnort: Berlin

Beruf: Staatlich geprüfter Techniker in Elektrotechnik / Informatik

  • Nachricht senden

16

Samstag, 14. September 2019, 23:25

Aber das Pfadproblem ist jetzt behoben oder ?

  • »Andreas Goller« ist männlich
  • Deutschland

Beiträge: 816

Wohnort: Rastatt

Beruf: Bauzeichner - halbtags

  • Nachricht senden

17

Samstag, 14. September 2019, 23:28

Hi Thorsten
Ja das mit den Pfaden klappt jetzt Prima :thumbsup:


Ja kannst mir auch schicken die Disk

Gruß Andi
Ich liebe den Sound vom C64´er 8o 8o

  • »Andreas Goller« ist männlich
  • Deutschland

Beiträge: 816

Wohnort: Rastatt

Beruf: Bauzeichner - halbtags

  • Nachricht senden

18

Sonntag, 15. September 2019, 00:31

Hi Thorsten
Also mir ist was aufgefallen beim Super Mario Bros 64. Wenn ich dein Diskversion spiele, ist die Kollisionsabfrage mit den Gegenstände im Spiel beim Emu64 ziemlich schlecht. Mario läuft fast bis zur hälfte in den Gegenstand hinein. Wenn ich die Fragenzeichen hole, wird der Stein um fast ein Char verstetz.
Mit Vice läuft das Wunderbar


hier mal ein Bild vom Emu64
https://www.bilder-upload.eu/bild-1cd799-1568500001.png.html

und hier ein Bild vom Vice
https://www.bilder-upload.eu/bild-c4cb92-1568500188.png.html

Ich hoffe du weis was man da machen kann.
Gruß Andi
Ich liebe den Sound vom C64´er 8o 8o

Peggy

Uhreinwohner

  • »Peggy« ist männlich
  • Deutschland

Beiträge: 692

Wohnort: Lage/Lippe

Beruf: KFZ-Elektriker

  • Nachricht senden

19

Sonntag, 15. September 2019, 11:15

Hiho,

nachdem ich heute dann auch mal die Zeit zum herumprobieren gefunden habe, ist mir bisher nur eines aufgefallen.

Bei dem Spiel Krakout geht es nach dem Krackintro und der Trainer/Highscore abfrage nicht weiter, der Bildschirm wird lediglich schwarz.

Bei der Gegenprobe mit Vice 3.1 zeigte sich das Krakout dort läuft. Somit würde ich erstmal davon ausgehen das, das Image soweit in Ordnung ist.

Plus auf Masse, das knallt Klasse.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Peggy« (15. September 2019, 11:24)


Thorsten Kattanek

Emu64 - Entwickler

  • »Thorsten Kattanek« ist männlich
  • »Thorsten Kattanek« ist der Autor dieses Themas
  • Deutschland

Beiträge: 1 310

Wohnort: Berlin

Beruf: Staatlich geprüfter Techniker in Elektrotechnik / Informatik

  • Nachricht senden

20

Montag, 16. September 2019, 10:13

Danke für eure Meldungen. Werde ich alles bei GitHub eintragen und mir anschauen. :thumbsup:

MfG Thorsten