Sie sind nicht angemeldet.

Bitte schaut euch auch ruhig den aktuellen Entwicklungsstand der Emu64 Version 5.xx an. Diese läuft schon recht stabil und rückt dem Ende der Portierung (Linux/windows) Woche für Woche immer näher.
https://bitbucket.org/tkattanek/emu64/wiki/Home

Kontrollzentrum

Geburtstage

Heute hat niemand Geburtstag.

Neue Benutzer

simun9(13. Juli 2017, 18:45)

Zeraphine(29. Juni 2017, 12:16)

Mister_Ormond(22. April 2017, 19:37)

rufus(5. April 2017, 21:09)

uwe kranz(25. März 2017, 11:56)

Zur Zeit sind keine Benutzer aktiv.

Statistik

  • Mitglieder: 826
  • Themen: 1097
  • Beiträge: 7055 (ø 1,77/Tag)
  • Wir begrüßen unser neuestes Mitglied: simun9

Umfrage

Lieber Besucher, herzlich willkommen bei: Emu64. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Montag, 12. Juli 2010, 21:46

Directory wird nicht angezeigt

Ich habe 2 D64-Dateien bei denen im Floppy-Menü kein Directory angezeigt wird:

1) Bei der Datei "Last Ninja a" erscheint "Fehler im D64 Image".
2) Auch bei der Datei "Last Ninja b" erscheint kein Directory. Es läßt sich dann allerdings mit LOAD"$",8 etc. doch anzeigen.

Grüße...
»purmike« hat folgende Dateien angehängt:
  • Last Ninja a.d64 (174,85 kB - 62 mal heruntergeladen - zuletzt: 18. April 2017, 11:00)
  • Last Ninja b.d64 (174,85 kB - 48 mal heruntergeladen - zuletzt: 4. Juli 2017, 21:25)
Gruß,

purmike

Thomas Daden

* Mugg / Giri *

  • »Thomas Daden« ist männlich
  • Deutschland

Beiträge: 1 699

Wohnort: Langen (Hessen)

Beruf: Techniker

  • Nachricht senden

2

Montag, 12. Juli 2010, 22:40

Irgendwo hier im Forum hatte wir das Thema schon mal und Thorsten hatte da was am Programm geschraubt ;) ...
Da hat der gute Thorsten wieder was zum Knobeln :D ...

Grüße,
Thomas

  • »Andreas Goller« ist männlich
  • Deutschland

Beiträge: 789

Wohnort: Rastatt

Beruf: Bauzeichner - halbtags

  • Nachricht senden

3

Dienstag, 13. Juli 2010, 09:59

Hi

Also es liegt nicht am Emu64 sonderen an dem Image. Ich habe folgendes gemacht, habe vom Emu64 eine neue Image erstellen lassen.
Um die Image um zu kopieren benutze ich den Total Commander, für ihn gibt es ein Plugin um die Image d64 zu öffnen.
Ich habe also alle Programme erst mal auf die Platte kopier. Dann habe ich alle Programme noch auf gross geschrieben und die Endung prg verpasst. Die hat nämlich bei allen Programmennamen gefehlt (Vielleicht lags daran).
Und dann habe ich alle Programmteil auf die neue Image kopiert, den Emu64 angeschmiessen und siehe da....... es geht. Alle Programme liefen ohne Probleme. Und das sollte auch mit der anderen so funzen. Das werde ich aber erst später machen. Habe jetzt keine Zeit.

Gruss Andreas :)
Ich liebe den Sound vom C64´er 8o 8o

4

Dienstag, 13. Juli 2010, 18:23

Interessanterweise kann man die Datei "Last Ninja a.d64" über die Command-Line problemlos mounten und dann über LOAD"$",8 das Directory laden.

Andere Emulatoren bzw. Tools haben auch kein Problem mit dem Image.

Grüße...
Gruß,

purmike

5

Dienstag, 13. Juli 2010, 19:56

Normalerweise zeigen die ersten beiden Bytes in der BAM (Blockbelegungsplan) auf Track 18 und Sektor 1. (Zeiger auf Directory)

Bei diesen beiden Images sind da aber utopische Werte über 60 bei Track und Sektor eingetragen und zeigen daher ins Nirvana!
Diese ungültigen Werte sollte Thorsten in Emu64 noch abfangen und durch Track 18 / Sektor 1 ersetzen.

Last Ninja a_bereinigt.d64
Last Ninja b_bereinigt.d64

mfg TJ

Thorsten Kattanek

Emu64 - Entwickler

  • »Thorsten Kattanek« ist männlich
  • Deutschland

Beiträge: 1 282

Wohnort: Berlin

Beruf: Konstruktion / CNC-Programmierer

  • Nachricht senden

6

Mittwoch, 14. Juli 2010, 19:39

Sowie ich dazu komme, schaue ich mir das mal an. Zur Zeit code ich an der neuen VICII Emu rum, die schon das eine oder andere besser aussehen lässt.
(War ich jetzt etwa Off Topic ??? :D )

MfG Thorsten
Ich möchte gerne die Welt verändern, doch Gott gibt den Quelltext nicht frei.

7

Dienstag, 21. Februar 2017, 19:56

Diskimage auch in 5.0 betroffen

Habe soeben ein Bug für die 5.0 erstellt, denn auch dort werden manche images nicht angezeigt, während andere Programme das Verzeichnis auflisten.

Gruss, Markus

Thorsten Kattanek

Emu64 - Entwickler

  • »Thorsten Kattanek« ist männlich
  • Deutschland

Beiträge: 1 282

Wohnort: Berlin

Beruf: Konstruktion / CNC-Programmierer

  • Nachricht senden

8

Mittwoch, 22. Februar 2017, 10:09

Ich habe den Eintrag bei Bitbucket schon gesehen. Werde ich mir demnächst anschauen.